Spartan Trouble-Shooting

This page describes some relatively common issues and their (potential) solutions

Start-Up Issues

It is common for the remote disk not to mount correctly if the Spartan computer is re-started (re-booted). This is different from re-starting the Spartan GUI, which retains the remote connection. If the remote disk does not mount when selected from the "Observing Set-Up" tab, what you need to do is the following:

  • Open the "My Computer" icon on the desktop (double-click)
  • Drive "M" will likely show a red "X"; click on the icon and it will ask for credentials to connect
  • Double-click on the icon labelled "ic7_connection", which is a text file listing the credentials. Enter these.
  • The remote drive should mount OK.
  • If it fails to do so (and you typed the credentials correctly), then it is probably necessary to ask someone to start the server process on ic7. That should not be required unless ic7 itself was restarted recently; check that you typed the disk mount credentials correctly first.

Generally, the instrument remembers where the mechanisms are positioned, so that all you need to do is specify where you want them to be. But in some cases (for example, system crash while moving a mechanism), you will need to re-initialize them. From the "Instrument" tab you can both test the home positions and find the home positions of each mechanism. If you need to initialize, use the "find" command for each of the 3 active mechanisms - Filter Wheel, Stop Wheel and Mask Wheel. (The camera mechanism is disabled, don't try to move that.) After the home position is located you will need to position each wheel to a useful position. For the mask wheel, this is "LR Open". This is the only time you will need to move the mask wheel. The figure below shows the relevant part of the interface.

If you want to, you can open the "Mechanism Homing" window from the "Window" menu on the menu bar at the tops; this lets you see things happening but is otherwise not needed.

If the instrument allows you to change filters at all, it is likely that the mechanism are positioning correctly. The "test home" allows you to check without resetting anything. The "home" positions should be a few hundred steps different from zero at most. The same "homing" window will let you watch this as well.

Recovery

If the system hangs, there are several levels of recovery available - try these in order.

  • From the "Instrument Tab", press the "Stop" button, then "Put Off Line". That button will change to "Put On Line" - press it again. The system will then initialize and take a test image. If that occurs, from the "Observing" tab click on the "See" button to the right of the object name (it should be set to "last" and "All det" below). This should bring up a ds9 window with the detectors; you may need to adjust the display parameters (in particular, scale to "zscale"). See the figure below.

  • If this doesn't work, you can restart the GUI. This is not the same as restarting the instrument computer! The steps are as follows:
    • From the leftmost "Operate" menu at the top of the GUI, select "Stop". The "run" arrow should appear on a menu bar just below; click on that to restart. This procedure will also work on the scripting GUI (TUI) if that is where the problem is happening.
    • If that fails to work, instead of clicking on the "run" arrow, open the "File" menu and click on "Exit"; click "Yes" on the prompt and the GUIs will all disappear. Now double-click on the "Spartan GUI" icon on the desktop. It will open and you can then click on the "run" arrow as above. This procedure will also close the scripting GUI (TUI); doing these steps on the TUI will also close both interfaces.
    • These last two steps are not much slower than the first one, but you will need to reset more parameters (observer name, remote directory, mechanism positions) as you progress.
  • The steps above will solve most problems, but if operation is still not nornal (especially, peculiar images), you may need to restart the computer and the Spartan electronics. If this is during the day, the day crew can help. The required steps are:
    • Shut down (do not "restart") the instrument computer (from Windows icon on left end of taskbar on desktop)
    • Have the operator turn off the instrument electronics
    • Allow time for capacitors, etc., to discharge - five minutes is sufficient.
    • Have the operator turn on the instrument electronics; wait for things to re-start (a couple of minutes)
    • Have the operator turn on the instrument computer; when it is ready for you to login your VNC connection will work again
    • Log in (usual observer log in)
    • Start the Spartan GUI as above
    • Note - this procedure applies if the problem behavior is uniform - e.g., problems with exposure times, all detectors have the same issue. If the problem is restricted to a single detector, then the day crew is required to review the connections internal to the detector electronics. Also note that problem quadrants on the detectors are due to wiring internal to the cryostate and cannot be solved by the day crew.